

<!DOCTYPE html>
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraph.org/schema/">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  <meta http-equiv="Content-Language" content="en-AU">
  
  <meta name="abstract" content="Channel Asia is the voice of the Asian IT channel.">
  <meta name="description" content="More tools to identify vulnerable applications and options to mitigate the risk from Spring4Shell are also now available.">
  <meta name="keywords" content="java, cyber security">
  <meta name="copyright" content="&copy; 2022 IDG Communications">
  <meta name="resource-type" content="document">
  <meta name="date" content="Monday, 11th April 2022">
  <meta name="robots" content="index,follow, noarchive">
  
  
  <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no, minimum-scale=1.0, maximum-scale=1.0">
  

  
<!--<script src='//twin-iq.kickfire.com/twin.js?14997'></script>-->
<link rel="apple-touch-icon" sizes="180x180" href="https://www.idgcdn.com.au/compressor-staticfiles/sg_channelasia/images/ico/apple-touch-icon.png?release=20220408180433">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.idgcdn.com.au/compressor-staticfiles/sg_channelasia/images/ico/favicon-32x32.png?release=20220408180433">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.idgcdn.com.au/compressor-staticfiles/sg_channelasia/images/ico/favicon-16x16.png?release=20220408180433">
<link rel="manifest" href="https://www.idgcdn.com.au/compressor-staticfiles/sg_channelasia/images/ico/site.webmanifest?release=20220408180433">
<link rel="mask-icon" href="https://www.idgcdn.com.au/compressor-staticfiles/sg_channelasia/images/ico/safari-pinned-tab.svg?release=20220408180433" color="#cc1616">
<meta name="google-site-verification" content="5qQ_zzzanc6Xljj_5R3kMP13H79_x9cVReoaKBDLPDQ" />
<meta name="msapplication-TileColor" content="#000000">
<meta name="msapplication-TileImage" content="https://www.idgcdn.com.au/compressor-staticfiles/sg_channelasia/images/ico/mstile-144x144.png?release=20220408180433">
<meta name="theme-color" content="#ffffff">

  
  <title>Spring4Shell patching is going slow but risk not comparable to Log4Shell - 
Channel Asia
</title>
  <!--[if lt IE 9]>
  <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->

  <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>
  





<meta property="og:title" content="Spring4Shell patching is going slow but risk not comparable to Log4Shell" />
<meta property="og:type" content="article" />
<meta property="og:image" id="shareimage1" content="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/600x315/dimg/cyber_code.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="315" />
<meta property="og:url" id="shareurl"content="https://channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/" />
<meta property="og:description" content="More tools to identify vulnerable applications and options to mitigate the risk from Spring4Shell are also now available." />
<meta property="og:image" id="shareimage2" content="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/180x110/dimg/cyber_code.jpg" />
<meta property="og:image:width" content="180" />
<meta property="og:image:height" content="110" />



<!-- The below is the code for twitter cards for all the article pages -->






<meta name="news_keywords" content="java, cyber security">



<link rel="canonical" href="https://www.csoonline.com/article/3656408/spring4shell-patching-is-going-slow-but-risk-not-comparable-to-log4shell.html" />


<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20220408180433" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/article.css?release=20220408180433" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/comment.css?release=20220408180433" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/social.css?release=20220408180433" media="all" rel="stylesheet" type="text/css">

<link rel="alternate" type="application/rss+xml" title="Channel Asia: java" href="/rss/tag/java/" />

<link rel="alternate" type="application/rss+xml" title="Channel Asia: cyber security" href="/rss/tag/cyber-security/" />

<link rel="alternate" type="application/rss+xml" title="Channel Asia: by Lucian Constantin" href="/rss/author/63577955/lucian-constantin/" />





<link href="https://www.idgcdn.com.au/compressor-staticfiles/social_login_sass.css?release=20220408180433" rel="stylesheet" type="text/css" />

<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20220408180433" media="all" rel="stylesheet" type="text/css">
<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/article/article_infinite.css?release=20220408180433" />

<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/arn/style.css?release=20220408180433" />
<link rel="stylesheet" type="text/css" media="all" href="https://www.idgcdn.com.au/compressor-staticfiles/polls/polls.css?release=20220408180433" />

  <link href="https://www.idgcdn.com.au/compressor-staticfiles/arn/arn.css?release=20220408180433" rel="stylesheet" type="text/css" />
  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/jobs/jobbox.css?release=20220408180433" media="screen,print" />
  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/brand_posts/style.css?release=20220408180433" media="screen,print" />
  <link href="https://www.idgcdn.com.au/compressor-staticfiles/arn_zones/nextdc_hub/slick.css?release=20220408180433" rel="stylesheet" type="text/css" />

    

<!--start Sourcepoint code-->

<script type="text/javascript">
    !function () { var e = function () { var e, t = "__tcfapiLocator", a = [], n = window; for (; n;) { try { if (n.frames[t]) { e = n; break } } catch (e) { } if (n === window.top) break; n = n.parent } e || (!function e() { var a = n.document, r = !!n.frames[t]; if (!r) if (a.body) { var i = a.createElement("iframe"); i.style.cssText = "display:none", i.name = t, a.body.appendChild(i) } else setTimeout(e, 5); return !r }(), n.__tcfapi = function () { for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++)n[r] = arguments[r]; if (!n.length) return a; if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) { var i = { gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub" }; "function" == typeof n[2] && n[2](i) } else a.push(n) }, n.addEventListener("message", (function (e) { var t = "string" == typeof e.data, a = {}; try { a = t ? JSON.parse(e.data) : e.data } catch (e) { } var n = a.__tcfapiCall; n && window.__tcfapi(n.command, n.version, (function (a, r) { var i = { __tcfapiReturn: { returnValue: a, success: r, callId: n.callId } }; t && (i = JSON.stringify(i)), e.source.postMessage(i, "*") }), n.parameter) }), !1)) }; "undefined" != typeof module ? module.exports = e : e() }();
</script>

<script>
        window._sp_ = {
                config: {
                     accountId: 146,
                     baseEndpoint: 'https://cmpv2.channelasia.tech' ,
        }
}
</script>
<script src="https://cmpv2.channelasia.tech/wrapperMessagingWithoutDetection.js"></script>
<!--end Sourcepoint code-->



	<script>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</script>

		<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
		<body>
		<script type="text/javascript">(function(){window['__CF$cv$params']={r:'681941c429355557',m:'dc10cc25a96508c5b5bc648ca5ffcb415a94a508-1629437713-1800-AbnxjWixxfW9ufQu9yaF4Z4+8ipQi9zUVtKJyLaleeIT+9mUHAO/ya71cyuI7big8WNZdRvtm5lr+x16UhgJY8v6oGnjm1NF980i4xGpHN4UnAHAZ7Aw+VBYnFUEKsA6mCvC6987Vm1jod0aPbI5WMk=',s:[0x6107d02fa0,0x03a9d30f70],}})();</script></body>
		<script>
		//copy this whole script block
		//if no cmp then execute as normal.
		window.idguk = window.idgau || {};
		window.idguk.cmp = window.idgau.cmp || {};

		(function(promise){
			promise.then(function(consentOk){
				const isDebug = !!window.idguk.cmp.isDebug ? window.idguk.cmp.isDebug() : false;
				if(isDebug)console.log('GDPR','kickfire - consentOk', consentOk);
				if(!consentOk)return;
				const ID = 14997;
				let atsScript = document.createElement('script');
				atsScript.src = '//twin-iq.kickfire.com/twin.js?'+ID;
				atsScript.async=!0
				document.body.appendChild(atsScript);
			});

		})(
			!!window.idguk.cmp.kickfire ? window.idguk.cmp.kickfire : {then:function(f){f(true);}}
		);
		</script>

<script>

function runTracking() {
      var detectClarityExist = setInterval(function () {
        //waiting until tracking exist
        if (clarity_tracking_starter) {
          clarity_tracking_starter();
          clearInterval(detectClarityExist);
        }
      }, 10)
} 

runTracking();

</script> 

  <script async src="//js-sec.indexww.com/ht/p/183980-175280945846324.js"></script>
  <script src="https://cdn.blueconic.net/idg.js"></script>
  <script type='text/javascript'>
  (function(w,d,s,src){var tag = d.createElement(s);var lastScript = d.getElementsByTagName(s)[0];tag.async = 1;tag.src = src;tag.setAttribute("data-cfasync","false");lastScript.parentNode.insertBefore(tag, lastScript);})(window, document, 'script', 'https://intent.sg.channelasia.tech/analytics.js');
</script>
  <script src="https://www.google.com/recaptcha/api.js"></script>
  
  
<meta property="fb:app_id" content="" />
<meta property="og:site_name" content="Channel Asia" />


  <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1724434721147660');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1724434721147660&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

  



<script src="https://www.idgcdn.com.au/compressor-staticfiles/permutive/adsbygoogle.js?release=20220408180433"></script>
<script>

  var adblockerOn;
  if( typeof canRunAds != "undefined" && canRunAds ){
    adblockerOn = false;
  }else{
    adblockerOn = true;
  }

  function getMetaDescription(){
    var metas = document.querySelectorAll('meta')
    for(var i=0;i<metas.length;i++){
        if(metas[i].getAttribute('name')==='description'){
          return (metas[i].getAttribute('content'));
        }
    }
    return ''
  }

  function getMetaKeywords(){
    var metas = document.querySelectorAll('meta')
    for(var i=0;i<metas.length;i++){
        if(metas[i].getAttribute('name')==='keywords'){
          var newStr = (metas[i].getAttribute('content'));
          return newStr.split(',');
        }
    }
    return []
  }

  !function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
  permutive.addon('web', {
    page: {
      type: "article",
      keywords: getMetaKeywords(),
      language: "en",
      tags: ['java', 'cyber security'],
      audience: "consumer",
      description: getMetaDescription(),
      article: {
        authors: "Lucian Constantin" === "None"?null:["Lucian Constantin"],
        description: "More tools to identify vulnerable applications and options to mitigate the risk from Spring4Shell are also now available." === "None"?null:"More tools to identify vulnerable applications and options to mitigate the risk from Spring4Shell are also now available.",
        id: "696920" === "None"?null:"696920",
        isInsiderContent: false,
        modifiedAt: "2022-04-06T06:43:52Z" === "None"?null:"2022-04-06T06:43:52Z",
        publishedAt: "2022-04-06T06:30:00Z" === "None"?null:"2022-04-06T06:30:00Z",
        source: "Channel Asia",
        title: "Spring4Shell patching is going slow but risk not comparable to Log4Shell",
        type: "Article" === "None"?null:"Article",
        purchaseIntent: "None" === "None"?null:"None"
      },
      ads: {
        adblocker: adblockerOn,
        enabled: true
      },
      gTax: {
        primaryIds: [],
        secondaryIds: []
      },
      tax: {
        primaryCategories: [],
        secondaryCategories: []
      }
    }
  });

window.permutive.track('User', {
  companySize: "None" === "None"?null:"None",
  country: "None" === "None"?null:"None",
  id: "None" === "None"?null:"None",
  jobIndustry: "None" === "None"?null:"None",
  jobPosition: "None" === "None"?null:"None",
  purchaseIntent: "None" === "None"?null:"None",
  loggedIn: false,
})

</script>
<script async src="https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js"></script>



  


  <link href="https://www.idgcdn.com.au/compressor-staticfiles/channel_asia_template_sass.css?release=20220408180433" rel="stylesheet" type="text/css" />
  
   
<link href="https://www.idgcdn.com.au/compressor-staticfiles/channel_asia_sg_sass.css?release=20220408180433" rel="stylesheet" type="text/css" />


 
</head>
<body class="arn lo-responsive  twocolumns_noLHS">

<header id="lo-header" class="lo-header" role="banner">
  <div class="lo-header_top">
    <div class="logo-warp">
      
      <a href="/" id="lo-logo" class="lo-logo">Channel Asia</a>
      
    </div>
    
    <div class="lo-leaderboard">
<div class="gpt-ad" id="gpt-ad-top-banner-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
    

    <div class="lo-nav_button" id="lo-nav_button"></div>
  </div>
  <nav class="lo-nav" id="lo-nav">
    <ul>
      <li class="search">
        <form action="/search/" method="get">
          <input type="search" placeholder="Search" name="q" class="text">
          <input type="submit" name="op" value="Submit">
        </form>
      </li>
      <li>
        <a href="/tax/news">News</a>
      </li>
      <!--<li>
        <a href="/advance/">Advance</a>
      </li>-->
      <li class="super">
        <a href="#">ANALYSIS</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <div class="main lo-nav_submenu">
              <ul>
                <li><a href="/tax/analysis">Analysis</a></li>
                <li><a href="/tax/profiles/">Profiles</a></li>
                <li><a href="/podcast/">Podcasts</a></li>
                <li><a href="/tax/executive_roundtables/">Executive Roundtables</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">ECOSYSTEM</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <div class="main lo-nav_submenu">
            <ul>
                <li><a href="/distributor_directory/">Distributor Directory</a></li>
                <li><a href="/vendor_directory/">Vendor Directory</a></li>
                <li><a href="/slideshow/">Gallery</a></li>
             </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="/event">Events</a>
        <div class="lo-nav_sub events">
          <div class="inner">
            <div class="placeholder" data-placeholder="sub_events_hotevents"></div>
            <div class="placeholder" data-placeholder="sub_events_latest"></div>
            <a class="lo-nav_more" href="/events/upcoming/">View all events</a>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">Content Hub</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <div class="main lo-nav_submenu">
              <ul>
                <li><a href="/brand-post/">Brand Posts</a></li>
                <li><a href="/microsites">Microsites</a></li>
                <li><a href="/brand-post/content/658749/channel-roadmap/">Channel Roadmap</a></li>
              </ul>
              <ul>
		            <li><a href="/webinar/">Webinars</a></li>
		            <li><a href="/video/">Videos</a></li>
                    <li><a href="/section/featured_whitepapers">Channel Asia Library</a></li>
              </ul>
              <ul>
<!--                <li><a href="/mediareleases/">Media Releases</a></li>-->
                <li><a href="/user/mailing_list">Subscribe online</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
      <li>
        <a href="/contacts/">Contact</a>
      </li>
      <li class="user super">
        
          <a href="#">Sign in</a>
        
        <div class="lo-nav_sub user">
          <div class="inner">
            
            <section class="existing">
              <h2>Existing Member</h2>
              <form action="/user/login/" accept-charset="UTF-8" method="get"><input type='hidden' name='csrfmiddlewaretoken' value='0l1aabDIsv7exLcFPSBlUuJzCvkQJ5LT47mJniZxY0y1cna8ubDT3NXDpCEnkWoD' />
                <input type="submit" name="op" value="Log in">
                <p class="forgot"><a href="/user/password/">Forgot password?</a></p>
              </form>
            </section>
            <section class="join">
              <h2>Join Channel Asia</h2>
              <p>Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.</p>
              <a href="/user/register/?location=top_nav_bar">Sign up now</a>
            </section>
            
          </div>
        </div>
      </li>
      <!--<li>
        <a href="/covid19/">Covid-19 Central</a>
      </li>-->
    </ul>
  </nav>
</header>

<div id="skin">
<div id="headerpromos"></div>
<div id="otp_target"></div>
<div id="noskin_bump" class="lo-skin_bump"></div>


<div id="main" class="lo-content skin_wrap channelasia_login_page">
<div class="lo-columns " id="site_columns">

  
    
    
    
    
  

  

  
  <div class="lo-column lo-main   " id="site_columns_main">
    
<div id="art-articles_wrap" class="art-articles_wrap art-articles_wrap_infinite">

  <div class="art-topbar" id="art-topbar">
    <div class="art-topbar_content">
      <a id="art-topbar_menu_button_arn" class="art-topbar_menu_button" href="#">Menu</a>

      <a class="art-topbar_logo" href="/">ARN</a>
      <div class="art-progress" id="art-progress">
        <div class="art-topbar_currect" id="art-topbar_currect">
          Spring4Shell patching is going slow but risk not comparable to Log4Shell
        </div>
        <div class="art-next" id="art-next">
          <a class="art-nextlink" id="art-nextlink" href="#"></a>
        </div>
      </div>
    </div>
    <div class="art-progress_bar" id="art-progress_bar"></div>
  </div>

  <div id="art-next_signifier" class="art-next_signifier">
    <div class="art-next_signifier_content">
      <span class="art-next_signifier_image" id="art-next_signifier_image"></span>
      <h3 class="art-next_signifier_title" id="art-next_signifier_title"></h3>
    </div>
  </div>


  

  <div itemscope itemtype="http://schema.org/Article" class="art-wrap article_wrap" id="article_wrap_696920" data-article-id="696920" data-article-headline="Spring4Shell patching is going slow but risk not comparable to Log4Shell" data-article-url="/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/">

    <meta itemprop="sourceOrganization" content="CSO (US)" />
    <article class="art-article full">

      <header class="art-header">
        <h1 itemprop="name" class="art-title">Spring4Shell patching is going slow but risk not comparable to Log4Shell</h1>
        <p class="art-sms sms">More tools to identify vulnerable applications and options to mitigate the risk from Spring4Shell are also now available.</p>

        
        

        
        



<div class="art-social article_social" id="article_social_0" data-article-id="696920" data-article-url="https://channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/">
	<div class="art-byline art-byline_withpic">

		
			<a class="art-author_pic" href="/author/63577955/lucian-constantin/articles">
			
				<img src="https://d2bs8hqp6qvsw6.cloudfront.net/author/100x100/authors/22udlxq0_400x400.jpg" alt="Lucian Constantin">
			
			</a>
		

		<span class="art-author">
		
      <!-- Condition to display the Channel Asia instead of Channel Asia Singapore for the authors on Channel Asia sites -->
			<a href="/author/63577955/lucian-constantin/articles">Lucian Constantin (CSO (US))</a>
		
		</span>

		
			<span class="art-date" itemprop="datePublished">06 April, 2022 06:30</span>
		
	</div>

	<ul class="art-share">
		<!-- <li class="comments_li"><a class="comments" href="#comments" data-disqus-identifier="/article/696920/">0</a></li> -->
		<li class="facebook_li"><a data-action="Like" data-label="Facebook" target="_blank" class="facebook" href="http://www.facebook.com/sharer.php?u=https%3A//channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/&amp;amp;t=Spring4Shell%20patching%20is%20going%20slow%20but%20risk%20not%20comparable%20to%20Log4Shell"></a></li>
		<li class="linkedin_li">
			<a data-action="share" data-label="LinkedIn" target="_blank" class="linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A//channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/&amp;title=Spring4Shell%20patching%20is%20going%20slow%20but%20risk%20not%20comparable%20to%20Log4Shell">
				<span class="s">share</span>
			</a>
		</li>
		<li class="twitter_li">
			<a data-action="Tweet" data-label="Twitter" target="_blank" class="twitter" href="http://twitter.com/share?text=Spring4Shell%20patching%20is%20going%20slow%20but%20risk%20not%20comparable%20to%20Log4Shell&amp;url=https%3A//channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/">

			</a>
		</li>
		<!-- <li class="gplus_li">
			<a data-action="+1" target="_blank" data-label="Google+" class="gplus" href="https://plus.google.com/share?url=https%3A//channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/">
			
			</a>
		</li> -->
		
		<li class="print_li">
			<a class="line print" title="print this article" href="/article/print/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/" rel="nofollow">
				print
			</a>
		</li>
		
		<li class="email_li">
			<a class="line email" title="email this article" href="mailto:?subject=Spring4Shell%20patching%20is%20going%20slow%20but%20risk%20not%20comparable%20to%20Log4Shell&amp;amp;body=https%3A//channelasia.tech/article/696920/spring4shell-patching-going-slow-risk-comparable-log4shell/">
				email
			</a>
		</li>
	</ul>
</div>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/social.js?release=20220408180433"></script>
<script>
// var social_float_disable = true;
</script>

        

        
        


        <div class="art-header_extra">
          
          
          <a href="#art-comments_696920" data-disqus-identifier="/article/696920/" class="art-comment_count">Comments</a>
        </div>

      </header>

      <div itemprop="articleBody" class="art-body body">

      
      
      
      
      <div class="story_images nocaption">
        <figure>
          
          <img alt="" src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/740x500/dimg/cyber_code.jpg">
          

          
          
          <span class="image-license">
            
            <span>Credit:  Dreamstime </span>
            
            
          </span>
          

        </figure>
        

        
      </div>
      
      
      



      

      













	

<p>Businesses have been at work since last week investigating whether their applications or third-party software products are vulnerable to <a href="https://www.csoonline.com/article/3655932/remote-code-execution-flaws-in-spring-and-spring-cloud-frameworks-put-java-apps-at-risk.html" rel="noopener" target="_blank">Spring4Shell</a>, a critical remote code execution (RCE) vulnerability impacting Spring Framework, one of the most popular development frameworks for Java applications. </p><p>While exploitation attempts have already been observed in the wild, the rate at which developers are updating their Spring instances appears to be slow going.</p><p><a href="https://www.sonatype.com/resources/springshell-exploit-resource-center" rel="nofollow noopener" target="_blank">According to Sonatype</a>, the company that maintains Maven Central, the biggest repository of Java components and libraries, 80 per cent of Spring downloads since March 31 when the flaw was confirmed have continued to be for vulnerable versions of the framework. Maven Central integrates with many development tools, so the data suggests that developers are not in a rush to upgrade their Spring instances.</p>
<div style="line-height:0;z-index:2000;position:relative">
</div>
<p>However, that doesn't mean that apps running unpatched versions of Spring are necessarily vulnerable. For the known exploits to work, applications need to meet several conditions that are typical in default configurations. Mitigation strategies can also be applied without upgrading the framework itself.</p><p><strong>Spring4Shell exploit prerequisites</strong></p><p>In addition to the original proof-of-concept exploit that was leaked publicly before a patch was available, several variations are circulating. Security researchers from Akamai <a href="https://www.akamai.com/blog/security/spring-core-spring4shell-zero-day?utm_campaign=F-MC-52611&amp;utm_source=Twitter&amp;utm_medium=social_DS" rel="nofollow noopener" target="_blank">observed attacks</a> with variants using both GET and POST requests, the GET one being more efficient because it allows attackers to exploit the vulnerability with only one request to the server.</p><p>Additionally, one variant of the exploit uses a code obfuscation technique that's meant to evade input filtering or detection rules applied by web application firewalls (WAFs).</p><p>The CERT team at German telecommunications giant Deutsche Telekom reported exploitation attempts hitting its honeypot servers since March 31. Microsoft's threat intelligence team also <a href="https://www.microsoft.com/security/blog/2022/04/04/springshell-rce-vulnerability-guidance-for-protecting-against-and-detecting-cve-2022-22965/#:~:text=for%20this%20vulnerability.-,Observed%20activity,-Microsoft%20regularly%20monitors" rel="nofollow noopener" target="_blank">reported</a> seeing a low volume of exploitation attempts hitting the company's cloud services. </p><p>Meanwhile the U.S. Cybersecurity and Infrastructure Agency (CISA) added Spring4Shell, also tracked as CVE-2022-22965, to its <a href="https://www.cisa.gov/known-exploited-vulnerabilities-catalog" rel="nofollow noopener" target="_blank">Known Exploited Vulnerabilities Catalog</a> on Monday.</p><p>The Spring4Shell vulnerability only impacts applications running on Java Development Kit (JDK9), which introduced a new API called class.getModule. This API gives attackers an alternative path to ClassLoader, a dangerous attribute whose parameters should not be externally controlled. </p><p>Spring had code blocking access to this attribute since 2010 when a similar vulnerability was patched, but the blacklist did not include the getModule API added in JDK9. Fortunately, JDK8, which does not allow this vulnerability to be exploited, remains the more popular runtime for Java applications in use.</p><p>Two other prerequisites for exploitation are that the vulnerable application needs to run under the Apache Tomcat web server and be deployed as a WAR (Web application ARchive) package. Fortunately, many Spring applications are created with Spring Boot, a related tool that allows the creation of standalone applications and which use the executable JAR (Java ARchive) format by default. These applications are not vulnerable.</p><p>An application also needs to use Spring Framework's data binding mechanism that allows developers to bind HTTP request parameters to a Java object to be vulnerable. Not all applications use this feature. However, one of the basic tutorials published on the Spring website for handling form submissions is vulnerable. Developers who followed this reference code might have introduced the vulnerability.</p><aside id="brand-post-promo-placeholder-slot"></aside><p><strong>Detecting applications vulnerable to Spring4Shell</strong></p><p>Several security researchers and companies have released free tools that can help detect vulnerable applications either locally or remotely. Researchers from cyber security firm JFrog released <a href="https://github.com/jfrog/jfrog-spring-tools" rel="nofollow noopener" target="_blank">a Python scanner</a> that can find possible instances of data binding in WAR and JAR files. Researcher Jan Schaumann released <a href="https://github.com/jschauma/check-springshell" rel="nofollow noopener" target="_blank">a similar file system scanner</a> in the form of a Linux shell script, and researcher Hilko Bengen released <a href="https://github.com/hillu/local-spring-vuln-scanner" rel="nofollow noopener" target="_blank">a scanner</a> written in Go.</p><p>Microsoft points out that a live application can be tested remotely by running the following request against it using the curl command line tool:</p><p><code>curl host:port/path?class.module.classLoader.URLs%5B0%5D=0</code></p><p>Researcher Florian Roth <a href="https://github.com/Neo23x0/signature-base/blob/master/yara/expl_spring4shell.yar" rel="nofollow noopener" target="_blank">published YARA rules</a> that can be used by defenders to check a system for a potentially successful compromise via Spring4Shell. The rules will detect malicious JSP backdoor files dropped by the known exploits.</p><p>The CERT Coordination Center at Carnegie Mellon University <a href="https://www.kb.cert.org/vuls/id/970766" rel="nofollow noopener" target="_blank">maintains a list of vendors</a> that have confirmed having vulnerable products as well as other who are still investigating. A French researcher known as SwitHak also compiled <a href="https://gist.github.com/SwitHak/0be6e857174d6ba2a6973f9ff9030c94" rel="nofollow noopener" target="_blank">a list of vendor responses and advisories</a> to Spring4Shell with the help of the infosec community.</p><p><strong>Mitigation for Spring4Shell</strong></p><p>The best way to mitigate this vulnerability is to update Spring Framework to versions 5.3.18 or 5.2.20 and Spring Boot to versions 2.6.6 or 2.5.12. However, if updating the framework is not immediately possible there are alternative workarounds.</p><p>For example, developers could add a @ControllerAdvice that blocks assignments to some of the ClassLoader internal fields to their applications. However, the Spring developers warned that this is not completely failsafe in some situations and provided more guidelines in <a href="https://spring.io/blog/2022/03/31/spring-framework-rce-early-announcement#suggested-workarounds" rel="nofollow noopener" target="_blank">their advisory.</a></p><p>Another temporary mitigation is to upgrade Tomcat to version 10.0.20, 9.0.62 or 8.5.78, which were released in response to Spring4Shell. The currently circulated exploits rely on the Tomcat-specific feature AccessLogValve to overwrite arbitrary files and deploy backdoors on servers, so the Tomcat developers released these new versions to close this attack vector. </p><p>However, while this might cripple the current exploit, it shouldn't be viewed as a long-term solution, as attackers could discover alternative attack vectors.</p><p>Despite the name similarity to <a href="https://www.csoonline.com/article/3645791/how-to-detect-log4shell-exposure-and-exploitation.html" rel="noopener" target="_blank">Log4Shell</a> -- a critical vulnerability discovered in December in the log4j Java logging library used in millions of applications -- Spring4Shell does not seem to have the same widespread impact, primarily because of steeper exploitation requirements that less applications meet. </p><p>That said, it is a serious vulnerability that will probably linger in enterprise applications for a long time. According to Sonatype's data, almost 40% of log4j2 downloads from Maven Central continue to be for vulnerable versions of the library three months after <a href="https://www.csoonline.com/article/3645791/how-to-detect-log4shell-exposure-and-exploitation.html" rel="noopener" target="_blank">Log</a>4<a href="https://www.csoonline.com/article/3645791/how-to-detect-log4shell-exposure-and-exploitation.html" rel="noopener" target="_blank">Shell</a> was announced.</p><aside class="fakesidebar">
</aside>





      





<div id="article_bottom_promo">
  
  
  <br><center>
<a href="/user/register/?destination=/user/mailing_list/" target="_blank"><img src="https://demo.idg.com.au/arn/ARNSurvey.png" width="280"></img></a>
</center>
  
</div>




      

        
      





<aside class="readmore" id="brand-post-in-article-promo">
  <div class="nocontent">
  <a class="image placeholder" href="/brand-post/content/692555/the-most-effective-response-to-the-exponential-rise-in-sophisticated-ransomware-is-partner-driven-data-resilience/" onclick="trackBrandPostNativeAdLink(692555);">
    <img src="https://d2bs8hqp6qvsw6.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/2020-07-21.png" />
  </a>

  <span class="text">
    <img class="brandpost_logo" src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/90x30/brand_post/post_type/brandpage_type.png">
    <a href="/brand-post/content/692555/the-most-effective-response-to-the-exponential-rise-in-sophisticated-ransomware-is-partner-driven-data-resilience/" onclick="trackBrandPostNativeAdLink(692555);">The Most Effective Response To The Exponential Rise In Sophisticated Ransomware Is Partner-Driven Data Resilience</a><br/>
  </span>

  <a class="more" href="/brand-post/276/dell-technologies/" onclick="trackBrandPostNativeAdLink(692555);">More from Dell Technologies</a>

  
  </div>
</aside>




<script type="text/javascript">
$(document).ready(function() {
  if(document.getElementById("brand-post-promo-placeholder-slot") !== null) {
    insertBrandPostReadMoreSlot();
  } else {
    insertBrandPostArticleMiddle();
  }
});

function insertBrandPostReadMoreSlot() {
  $('#brand-post-promo-placeholder-slot').replaceWith($('#brand-post-in-article-promo'));
}

function insertBrandPostArticleMiddle() {
  var pos = $('article.full .body > .storybody').length;
  if (pos > 5) {
    pos = Math.round(pos / 2);
  }
  
  $('article.full .body > .storybody').each(function(index, object){  
    if (index == pos) {
      $(this).after($('#brand-post-in-article-promo'));
    }
  });
}
</script>




<script type="text/javascript">
function trackBrandPostNativeAdLink(nid) {
  ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-' + nid, {'nonInteraction': 1});
}
</script>



      


      
      

      


        
      
      <p class="tags">
        Tags <a href="/tag/java/">java</a><a href="/tag/cyber-security/">cyber security</a>
      </p>
      
      
      
      



      

<aside class="art-readnext readnext">
  <div class="nocontent">
  <h2 class="lo-title center">Read next</h2>
  <ul>
    
    
    
    <li>
      
      
          

      <a class="image" href="/article/697023/crowdstrike-mandiant-form-strategic-partnership-protect-organisations-against-cyber-threats/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20220408180433" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/190x190/dimg/microsoftteams-image_4_1.png"></a>
      <h3><a href="/article/697023/crowdstrike-mandiant-form-strategic-partnership-protect-organisations-against-cyber-threats/">CrowdStrike and Mandiant form strategic cyber threat partnership</a></h3>

      

    </li>
    
    <li>
      
      
          

      <a class="image" href="/article/697000/ai-takes-aim-employee-turnover/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20220408180433" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/190x190/dimg/dreamstime_s_142783746.jpg"></a>
      <h3><a href="/article/697000/ai-takes-aim-employee-turnover/">AI takes aim at employee turnover</a></h3>

      

    </li>
    
    

    
    
    
    
    <li class="gallery">
      <a class="image" href="/slideshow/690262/channel-asia-hosts-industry-leaders-inaugural-hall-fame-lunch-2021/"><img src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/190x190/dimg/bill_chang.jpg"></a>
      <h3><a href="/slideshow/690262/channel-asia-hosts-industry-leaders-inaugural-hall-fame-lunch-2021/">Channel Asia Hall of Fame</a></h3>
    </li>
    
    
    
  </ul>
  </div>
</aside>



      </div><!-- body -->

    </article>


    <div class="art-sidebar">
      
      

  
    <aside class="rhs-follow-us">
      <h2 class="lo-title">Follow us</h2>
      <ul class="">
        <li class="twitter"><a href="https://twitter.com/ChannelAsiaTech" target="_blank" title="Twitter">Twitter</a></li>
        <li class="facebook"><a href="https://www.facebook.com/ChannelAsiaTech/" target="_blank" title="Facebook">Facebook</a></li>
        <li class="linkedin"><a href="https://www.linkedin.com/company/13678188/" target="_blank" title="LinkedIn">LinkedIn</a></li>
        <li class="rss"><a href="/rss/tax/news/" target="_blank" title="RSS">RSS</a></li>
      </ul>
    </aside>
  

  
  
  <div class="rhs_boombox">
<div class="gpt-ad" id="gpt-ad-right-hand-side-story-list-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
  
  

  <!--  promo unit -->
  
  
  <div class="module-rhs-brandpost">
    <h2 class="lo-title">Events</h2>
    <article id="event-promo">
    
    <div>
      <a class="main-img" href="https://www.idgevents.com/ChannelAsiaWIICTA">
        <img src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/300x300/promoted_content/promo/channel-asia-hero-image_1.png">
      </a>
      <h3 class="title">
        <a href="https://www.idgevents.com/ChannelAsiaWIICTA" title="Channel Asia WIICTA 2022">Channel Asia WIICTA 2022</a>
      </h3>
      
    </div>
    
    </article>
  </div>
  
  <!-- / promo unit -->


  


  

  
    



<div class="module-rhs-brandpost">
  <h2 class="lo-title">Brand Post</h2>
  <article>
    
    
    
    <h3 class="title">
      <a href="/brand-post/content/692555/the-most-effective-response-to-the-exponential-rise-in-sophisticated-ransomware-is-partner-driven-data-resilience/" onclick="trackBrandPostNativeAdLink(692555);">
        The Most Effective Response To The Exponential Rise In Sophisticated Ransomware Is Partner-Driven Data Resilience
      </a>
    </h3>
   
    
    <div class="sponsor">
      <span>Sponsored By</span>
      <a href="/brand-post/276/dell-technologies/" title="Dell Technologies" onclick="trackBrandPostNativeAdLink(692555);">
          <img src="https://d2bs8hqp6qvsw6.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/2020-07-21.png"  alt="Dell Technologies"/>
      </a>
    </div>
  </article>
</div>







<script type="text/javascript">
function trackBrandPostNativeAdLink(nid) {
  ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-' + nid, {'nonInteraction': 1});
}
</script>


  


  
<section class="lo-rhs_upcoming">
  
  




  
</section>






  

<aside>
  <div class="nocontent">
  <h2 class="lo-title">Related Whitepapers</h2>
  <ul class="related_list whitepapers">
  
  </ul>
  </div>
</aside>



  
  
  
  <div class="rhs_block rhs_block_ad">
    <div class="content">
<div class="gpt-ad" id="gpt-ad-right-hand-side-feature-box-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[300, 150]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[0, 0], [[300, 150]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
  </div>
  
  


  
  
  <div class="rhs_block rhs_boombox">
    <div class="content">
<div class="gpt-ad" id="gpt-ad-right-hand-side-boombox-standard-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

 </div>
  </div>
  
  

  



      
    </div>



    <div class="art-extra">

    
    <div class="art-comments" id="art-comments_696920">
    <a class="art-comment_show" data-disqus-identifier="/article/696920/" data-disqus-shortname="channelasia-singapore" href="#">Show Comments</a>
<div id="disqus_thread" data-disqus-shortname="channelasia-singapore" data-disqus-identifier="/article/696920/"></div>
<script type="text/javascript">
var disqus_shortname = 'channelasia-singapore';
var disqus_identifier = '/article/696920/';
var disqus_init = false;
function disqus_config() {
	this.callbacks.onReady = [function() {
		if (disqus_init) return;
		disqus_init = true;

		if ($('.art-articles_wrap_infinite').length == 0) return;

		var comment_text = $('.art-comment_show').first().text();
		if (comment_text == '0 Comments') {
			$(".art-comment_show_activated").removeClass("art-comment_show_activated");
			$('#disqus_thread').hide();
		}
	}];
}

(function() {
	$('.art-comment_show').first().addClass('art-comment_show_activated');
	var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>

    </div>
      



      

      
      <div class="lo-bottom_boombox bottom_boombox">
      
<div class="gpt-ad" id="gpt-ad-main-column-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


      </div>
      


      <!-- <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/article.js?release=20220408180433"></script> -->

      



      
<script type="text/javascript">
(function() {
  var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
  po.src = 'https://apis.google.com/js/plusone.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
</script>



    </div>

    


    
    
    <div id="leaderboard-bottom-ad" class="art-bottom_leaderboard lo-leaderboard_bottom">
<div class="gpt-ad" id="gpt-ad-bottom-banner-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>  
    
    


    
    



<div class="ias-pagination" id="ias-pagination_696920">
	<a class="ias-next" data-sms="Targeting referral partners, VARs, distributors, MSPs and MSSPs and OEMs." data-image="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/200x200/dimg/helpsystems.jpg" title="HelpSystems launches channel program" data-article-nextid="696191" href="/article/696191/helpsystems-launches-channel-program/">HelpSystems launches channel program</a>
</div>

    

    
    <div id="clarity-context-data_696920" data-context="{&quot;event_type&quot;: &quot;pageview&quot;, &quot;tags&quot;: [&quot;java&quot;, &quot;cyber security&quot;], &quot;author&quot;: &quot;Lucian Constantin&quot;, &quot;word_count&quot;: 935, &quot;publication_datetime&quot;: &quot;2022-04-05T20:30:00+00:00&quot;, &quot;score&quot;: 1, &quot;content_type&quot;: &quot;article&quot;, &quot;content_id&quot;: 1059727200}">

    



  </div><!-- art-wrap -->




</div><!-- art-articles_wrap -->










  </div><!-- site_columns_main -->
  





  <div class="clearing">&nbsp;</div><!-- This is for NN6 -->

    












</div><!-- main -->


</div><!-- skin -->


<footer class="lo-footer">
  <div class="lo-footer_content">
    <img class="lo-footer_idg" src="https://demo.idg.com.au/idg_logo_footer.gif" alt="">
    <div class="lo-footer_text">
      <p class="lo-footer_copyright">Copyright &copy; 2022 IDG Communications, Inc. ABN 14 001 592 650. All rights reserved. Reproduction in whole or in part in any form or medium without express written permission of IDG Communications, Inc. is prohibited.</p>
      <div class="lo-footer_audit">
      <a href="http://www.auditbureau.org.au/edata/masthead/show/arn" target="_blank"><img src="https://demo.idg.com.au/idg/ABA_audited_website.gif" alt="ABA Audited Website"></a>
      </div>
      <p class="lo-footer_site">
      IDG Channel Sites:
      <a href="https://www.channelasia.tech" target="_blank">Channel Asia</a> |
      <a href="https://www.arnnet.com.au/" target="_blank">ARN</a> |
      <a href="https://www.reseller.co.nz/" target="_blank">Reseller News</a>
      </p>
      <p class="lo-footer_links">
      Links: <a href="/privacy">Privacy Policy [Updated 13 Sep 19]</a> <span class="cmpSettings cmpReshowLink" style="display:none;"> |<!--injected--> </span>| <a href="https://idg.com.au/reprint/">Reprints</a> | <a href="http://www.idg.com.au/contacts">Advertising</a>
      </p>
    </div>
  </div>
</footer>
<div class="lo-script">
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/arn/arn.js?release=20220408180433"></script>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/lazysizes.min.js?release=20220408180433"></script>
<script src="https://www.idgcdn.com.au/compressor-staticfiles/arn_zones/nextdc_hub/slick.min.js?release=20220408180433" type="text/javascript"></script>
<script>
	$(document).ready(function(){
		$('#event-promo').slick({
			slidesToShow: 1,
      slidesToScroll: 1,
      infinite: true,
      speed: 500,
      fade: true,
      cssEase: 'linear',
      arrows: false,
      dots: true,
      autoplay: true,
      autoplaySpeed: 3000
		});
	});
</script>
<script>
  
  $(function() {
    if (typeof $.fn.lazyload === 'undefined' ) {
      if ('loading' in HTMLImageElement.prototype) {
          const images = document.querySelectorAll('img[loading="lazy"]');
          images.forEach(img => {
            img.src = img.dataset.original;
          });
      }
      else {
        $.getScript('https://www.pcworld.com/www/js/jquery/jquery.lazyload.min.js',function(){
           $("img.lazy").lazyload({ 
              effect : "fadeIn", 
              threshold: 200,
              failure_limit:25
           });
        });
      }
    }
  });
  
  </script>

<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({appId: '', status: true, cookie: true,
			xfbml: true});
	};
	(function() {
		var e = document.createElement('script'); e.async = true;
		e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
		document.getElementById('fb-root').appendChild(e);
	}());
</script>

<!--<script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/arn/js/rhs/directory_search.js?release=20220408180433" defer></script>-->

  
  <script>
    var disqus_shortname = "";
  </script>
  <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery.magnific-popup.min.js?release=20220408180433"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery-ias.min.js?release=20220408180433"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/infinitescroll.js?release=20220408180433"></script>
  <script>
    ias_init('Channel Asia');
  </script>

<div id="trackers">


<!-- Start Google Analytics  -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-113224130-2', 'auto');

ga('require', 'displayfeatures'); // enables demographics and interests reports


	ga('set', 'dimension1', "none");



	ga('set', 'dimension2', "lucian-constantin");



	ga('set', 'dimension3', "none");



	ga('set', 'dimension4', "none");



	ga('set', 'dimension5', "anonymous");



	ga('send', 'pageview');


// pageTracker._trackPageLoadTime();


// event tracking is asynchronous
function trackEvent(category, action, label, value) {
	if (value)
		ga('send', 'event', category, action, label, value, {'nonInteraction': 1});
	else
		ga('send', 'event', category, action, label, {'nonInteraction': 1});
}



trackEvent('Content Tags', 'Tag Impression', 'java');

trackEvent('Content Tags', 'Tag Impression', 'cyber security');

trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-692555');

trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-692555');



</script>
<!-- End Google Analytics -->



</div>


<div id="ad_slot"></div>


<div class="ad_scripts">

<div class="gpt-ad" id="gpt-ad-skin-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[1600, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[610, 100], [[1600, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-over-the-page-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[1, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[610, 610], [[1, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>






<div class="gpt-ad" id="gpt-ad-mobile-floating-banner-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[320, 50]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[600, 800], []], [[0, 0], [[320, 50]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-mobile-otp-7849208" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_sg.ChannelAsia.tech/networking_section" data-gpt-sizes="[[2, 2]]" data-gpt-targeting='{&quot;node&quot;: [&quot;696920&quot;], &quot;type&quot;: [&quot;article&quot;], &quot;sect&quot;: [&quot;networking&quot;, &quot;apps&quot;, &quot;digital&quot;, &quot;services&quot;, &quot;news&quot;, &quot;security&quot;, &quot;cloud&quot;, &quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;]}' data-gpt-size-mapping="[[[610, 610], []], [[0, 0], [[2, 2]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/adsmin/idg_gpt.js?release=20220408180433" charset="utf-8"></script>
<script type="text/javascript">
createAndDisplayAds();
</script>
</div>


<div class="load_dropcontent" id="load_dropcontent">
  <dl class="latest" data-load="sub_events_latest">
    
    
    
    

    
    
    
    <h2>Industry Events</h2>
    
    <dt>26 May</dt>
    <dd><a title="Channel Asia WIICTA 2022" href="/event/4618/channel-asia-wiicta-2022">Channel Asia WIICTA 2022</a></dd>
    
    

    <dd><a class="more" href="/events/upcoming/">View all events</a></dd>
    
  </dl>

  
  <div class="hotevents" data-load="sub_events_hotevents">
    
    
    
      <h2>Featured</h2>
      <ul class="lo-event_promos">
      
        <li>
          <article class="lo-event_promo">
            <a class="lo-event_promo_image" href="https://www.idgevents.com/ChannelAsiaWIICTA">
              <img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20220408180433" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/channel-asia-wiicta-featured-image-250-x100.png" alt="Channel Asia WIICTA">
              <p class="lo-event_promo_summary">Women in ICT Awards</p>
            </a>
            <h3 class="lo-event_promo_title"><a href="https://www.idgevents.com/ChannelAsiaWIICTA">Channel Asia WIICTA</a></h3>
          </article>
        </li>
      
      </ul>
    
    
  </div>
  

</div>

<script>
  $('#load_dropcontent [data-load]').each(function() { $("[data-placeholder="+$(this).data('load')+"]").replaceWith(this); });
</script>


<script type="text/javascript">
var disqus_shortname = 'channelasia-singapore';

/*
(function () {
var s = document.createElement('script'); s.async = true;
s.type = 'text/javascript';
s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
}());
*/

// This lets us know when the JS has loaded and after the counts are fetched.
function disqus_counts_loaded() {
	DISQUSWIDGETS.old_displayCount = DISQUSWIDGETS.displayCount;

	// Override the old displayCount() with a new one so we can attach our helper onto it.
	DISQUSWIDGETS.displayCount = function(arg) {
		DISQUSWIDGETS.old_displayCount(arg);
		$("a[href$=#disqus_thread],*[data-disqus-identifier]").trigger('disqus-counts-loaded');
	}
}

$.getScript('//' + disqus_shortname + '.disqus.com/count.js', disqus_counts_loaded);
</script>




<!-- Crazy Egg Tracking -->
<script type="text/javascript">
setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0018/8767.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>



<!-- Twitter universal website tag code -->
<script>
!function(e,n,u,a){e.twq||(a=e.twq=function(){a.exe?a.exe.apply(a,arguments):
a.queue.push(arguments);},a.version='1',a.queue=[],t=n.createElement(u),
t.async=!0,t.src='//static.ads-twitter.com/uwt.js',s=n.getElementsByTagName(u)[0],
s.parentNode.insertBefore(t,s))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nv5jw');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->

<!-- Taboola Pixel Code -->
<script type='text/javascript'>
  window._tfa = window._tfa || [];
  window._tfa.push({notify: 'event', name: 'page_view', id: 1009432});
  !function (t, f, a, x) {
         if (!document.getElementById(x)) {
            t.async = 1;t.src = a;t.id=x;f.parentNode.insertBefore(t, f);
         }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/unip/1009432/tfa.js',
  'tb_tfa_script');
</script>
<noscript>
  <img src='//trc.taboola.com/1009432/log/3/unip?en=page_view'
      width='0' height='0' style='display:none'/>
</noscript>
<!-- End of Taboola Pixel Code -->


<script type="text/javascript"> _linkedin_data_partner_id = "186603"; </script>
<script type="text/javascript"> 
    (function(){
        var s = document.getElementsByTagName("script")[0]; 
        var b = document.createElement("script"); 
        b.type = "text/javascript";
        b.async = true; 
        b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js"; 
        s.parentNode.insertBefore(b, s);
    })(); 
</script> 
<noscript>
    <img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=186603&fmt=gif" />
</noscript>




<script type="text/javascript">
  var clarity_tracking_starter = function (override_context_data) {
    var d=document;
    var id = 'idg-tracking';
    var s='script';
    var js, fjs = d.getElementsByTagName(s)[0];

    if (d.getElementById(id)) {
      runClarity();
      return false
    }
    
    js = d.createElement(s); 
    js.id = id; 
    js.type = "text/javascript";
    js.onload = function () {runClarity()};
    js.src = "https://www.idgcdn.com.au/compressor-staticfiles/clarity/idg_clarity.js?release=20220408180433";
    fjs.parentNode.insertBefore(js, fjs);

    function runClarity(){
      var dynamic_key_val_api = "/script-tagger/clarity/json/";
      var first_page_context_data = {
        'event_type':"pageview",'tags':["java", "cyber security"],'author':"Lucian Constantin",'word_count':935,'publication_datetime':"2022-04-05T20:30:00+00:00",'score':1,'content_type':"article",'content_id':1059727200
      }

      // Context data can be overridden and is used on infinite scroll pages to pass in 
      // context of the new article that is loaded on the page.
      var context_data = override_context_data || first_page_context_data;

      clarity_logger.init(
        dynamic_key_val_api,
        'https://clarity-api-prod.idg.com.au/collect/client', 
        context_data
      );
    }
  };
</script> 



  

<!--  additional tracking for twitter -->

<!-- Twitter single-event website tag code -->
<script src="//platform.twitter.com/oct.js" type="text/javascript"></script>
<script type="text/javascript">twttr.conversion.trackPid('nw1at', { tw_sale_amount: 0, tw_order_quantity: 0 });</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=nw1at&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
<img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=nw1at&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
</noscript>
<!-- End Twitter single-event website tag code -->






<!--  additional tracking for linkedin -->

<script type="text/javascript">
_linkedin_partner_id = "259747";
window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
  b.type = "text/javascript";b.async = true;
  b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
  s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
  <img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=259747&fmt=gif" />
</noscript>



</div><!-- lo-script -->
</body></html>
